What version Plex Media Server is required?

You need to run Plex Media Server version 0.9.11.5 or newer. You can always find the current releases on our Downloads page.

Version 0.9.12.8 or higher is needed to make use of our Plex Companion feature with the Plex for Xbox 360 app.

Related Page: Plex Downloads
Related Page: Plex Apps > Plex Companion