Will Plex work on my older iOS devices?

The current Plex for iOS app takes advantage of new features provided in later versions of iOS and, as such, devices must be running iOS version 8.1 or later.

If you previously purchased the app

If you previously purchased the Plex for iOS app and want to install it on a device that doesn't support the iOS 8.1 operating system, you can download the older 3.5.3 version from your purchase history provided your older device is running iOS 5.1 or higher.

To download the earlier (no longer supported) 3.5.3 version of the app, follow these steps:

  1. Open the App Store on your older device.
  2. Go to the Purchased screen.
  3. Find the Plex app and choose Download. You'll see a message telling you a compatible version is available. Tap Confirm to install this older version.

Warning!: The older 3.5.3 version of the app is no longer actively supported by Plex. It is available "as-is" to previous purchasers to install on older devices only.

What if I don't have a previous purchase?

Unfortunately, if you have not previously purchased the Plex for iOS app, the old version will not be visible in the App Store and won't be available to download.

You will need to be using an iOS device running iOS version 8.1 or later in order to enjoy the Plex for iOS app.