Which NAS devices are no longer supported starting with 0.9.17.0 server?

Starting with Plex Media Server version 0.9.17.0, NAS devices that use the following processors or operating systems are no longer supported.

  • ARMv5 processors
  • PowerPC (PPC) processors
  • 32-bit processors for unRAID
  • ReadyNAS OS 4 (ROS4) operating system

That means that Plex Media Server versions 0.9.17.0 and newer will not be available and will not run on those devices.

Note: Existing installs of older Plex Media Server versions will continue to function as they did before, but newer versions will not be available for those platforms.

Previously-supported devices that will be affected by this are listed below (note that this list won't necessarily list every single affected model):

Netgear

ARMv5

  • Duo
  • Duo v2
  • NV+
  • NV+ v2
  • NVX
  • RN1000
  • RN1000s
  • RN1100
  • (and all other ARMv5-based models)

ReadyNAS OS 4 (ROS4)

  • 2100
  • 2100v2
  • 3100
  • 3200
  • 4200
  • Pro 2
  • Pro 4
  • Pro 6
  • Pro Business
  • Pro Pioneer
  • Ultra 2
  • Ultra 2 Plus
  • Ultra 4
  • Ultra 4 Plus
  • Ultra 6
  • Ultra 6 Plus
  • (and all other models running ROS4)

QNAP

ARMv5

  • HS-210
  • TS-112
  • TS-119P II
  • TS-212
  • TS-219P II
  • TS-412
  • TS-410
  • TS-410U
  • TS-419P II
  • TS-420
  • (and all other ARMv5-based models)

Synology

ARMv5

  • DS109
  • DS110j
  • DS111
  • DS112
  • DS112+
  • DS112j
  • DS209
  • DS210j
  • DS211
  • DS211+
  • DS211j
  • DS212
  • DS212+
  • DS212j
  • DS213
  • DS213air
  • DS409
  • DS409slim
  • DS410j
  • DS411
  • DS411j
  • DS411slim
  • DS413j
  • RS409
  • (and all other ARMv5-based models)

PPC

  • DS109+
  • DS109j
  • DS110+
  • DS209+
  • DS209+II
  • DS209j
  • DS210+
  • DS213+
  • DS406e
  • DS408
  • DS409+
  • DS410
  • DS413
  • DS509+
  • RS409(RP)+
  • x07/x01 Series
  • x08/x06 Series
  • (and all other PowerPC-based models)

Thecus

PPC

  • N2310
  • N4310
  • (and all other PowerPC-based models)

unRAID

The 32-bit build for unRAID will no longer be available. Nearly any modern device running unRAID should be on a 64-bit processor and thus able to run the 64-bit build instead.

Western Digital

ARMv5

  • WD My Cloud EX4
  • (and all other ARMv5-based models)